Summera områden med felmeddelande

Om man ska summera ett område i Excel och använder sig av funktionen SUMMA (SUM) så brukar det aldrig vara några bekymmer. Men om det finns ett eller flera felmeddelande i området som exempelvis #VÄRDEFEL!, #DIVISION/0! (#VALUE!, DIV/0!) så kan inte området summeras. Funktionen SUMMA kan inte ignorera celler med felmeddelande utan försöker räkna med dessa celler och då går det inte.

Summera område med felmeddelanden        Summera område med felmeddelanden

Ladda ner exempelfilen här.

Det finns olika lösningar för att kunna beräkna områden som innehåller felmeddelande. I grund och botten gäller det att hantera cellerna med felmeddelande på något sätt.

Vi rekommenderar dessa Excelkurser:
www.infocell.se – lärarledda kvalitetskurser i Excel
www.officekurs.se – oslagbar e-Learning i Excel & Office-paketet

Lösning 1

Genom att blanda in ytterligare en funktion för att hantera alla celler med felmeddelanden, nämligen OMFEL (IFERROR). Med denna funktion talar vi om att alla celler som innehåller ett felmeddelande ska ersättas med värdet 0 istället. Detta kommer inte att påverka den totala beräkningen men löser problemet.

Men det finns en hake med denna lösning och det är man måste ange den totala formeln som en matrisformel för att den ska fungera.

=SUMMA(OMFEL(D3:D6;0))        =SUM(IFERROR(D3:D6;0))

För att denna formel ska fungera måste den bekräftas med Ctrl + Shift + Enter. Då blir det en matrisformel som kan hantera flera operationer i samma formel. När man gör en matrisformel så blir det klammerparenteser (måsvingar) { } runt om formeln. Om man ska redigera formeln i efterhand måste man bekräfta med Ctrl + Shift + Enter.

OMFEL (IFERROR) kontrollerar hela området och ersätter celler som innehåller felmeddelande med värdet 0. Sedan summeras det hela med SUMMA.

Lösning 2

Den andra lösningen är att använda ett helt annan mångsidig funktion nämligen MÄNGD (AGGREGATE). Denna funktion innehåller flera funktioner med olika alternativ för beräkningar vilket gör den väldigt användbar. Utan att gå in för djupt på MÄNGD så visar vi lösningen för problemet här.

=MÄNGD(9;6;D3:D6)           =AGGREGATE(9;6;D3:D6)

Första argumentet (9) talar om att funktionen SUMMA (SUM) ska användas. Det finns totalt 19 olika funktioner som kan användas. Det andra argumentet (6) är ett alternativ för hur beräkningen ska göras och detta alternativ ”ignorerar felvärden”. Det finns totalt 8 olika alternativ att välja bland. Till sist anges området med värden som ska beräknas och sedan bekräfta som vanligt.

Summera område med felmeddelanden

Detta var lösningen för att summera områden med felmeddelande. Men dessa lösningar fungera även om man vill göra andra beräkningar på områden med felmeddelande.

Tänk på att använda Ctrl + Shift + Enter för att skapa matrisformel.

Prova även funktionen MÄNGD (AGGREGATE) och se vilka alternativ som finns.

Du gillar kanske också...