Summera enbart positiva eller negativa värden

Det finns flera exempel på när man vill summera ett område med ett villkor. Då kan du med fördel använda funktionen SUMMA.OMF [SUMIFS]. Denna funktion är verkligen användbar och löser enklare till med komplexa summeringar där summeringen enbart ska vara på specifika värden som anges i ett villkor. I detta tips ska vi se hur man kan summera enbart positiva värden (eller negativa värden) när det i området finns en blandning.

Utgångsläget är att vi har en lista med blandade positiva och negativa värden (se bilden).

Utifrån värdena i B-kolumnen ska vi nu summera enbart positiva värden och sedan även enbart negativa värden.

Vi rekommenderar dessa Excelkurser:
www.infocell.se – lärarledda kvalitetskurser i Excel
www.officekurs.se – oslagbar e-kurser i Excel & Office-paketet

Ladda ner exempelfilen här.

Summera enbart positiva värden

Funktionen SUMMA.OMF [SUMIFS] har tre argument som måste anges. Ett summaområde och sedan ett villkorsområde med tillhörande villkor. Det gåt även att bygga ut funktionen med flera villkor om man önskar men i detta exempel har vi endast ett villkor.

Formeln för att summera positiva värden blir:

=SUMMA.OMF(B2:B21;B2:B21;”>0″)

=SUMIFS(B2:B21;B2:B21;”>0″)

Första argumentet är summaområde (där värdena som ska summeras finns). Andra argumentet villkorsområde är där villkoret ska appliceras, vilket i detta fall sammanfaller med summaområdet. Sista argumentet villkor ska skrivas inom citattecken. Då vi enbart ska summera positiva värden blir villkoret större än noll och skrivs ”>0”.

Resultatet från formeln blir då att enbart positiva värden summeras.

Summera enbart negativa värden

För att enbart summera negativa värden så är det bara att använda samma formel som tidigare men vi byter bara villkoret.

=SUMMA.OMF(B2:B21;B2:B21;”<0″)

=SUMIFS(B2:B21;B2:B21;”<0″)

Vi ser i formeln att villkoret nu är villkoret satt till mindre än noll och därmed summeras enbart negativa värden.

Fler alternativ

Funktionen SUMMA.OMF [SUMIFS] fungerar utmärkt att använda på listor/tabeller. Förutsättningarna är att summaområdet och villkorsområdet är lika stort, men kan vara olika kolumner. I exemplen i detta tips har villkoren gällt för värden/tal men man kan sätta villkor som gäller för text eller datum också. Dessutom kan man använda flera villkor för att snäva in resultatet ytterligare.

 

Klicka vidare till www.officekurs.se för att se alla våra webbaserade kurser i Excel och övriga Office.

Du gillar kanske också...