Låsa tabellreferenser

Att använda tabeller som underlag i Excel är på många sätt mycket användbart. Med tabeller så får du tillgång till flera verktyg samt att dynamiken då underlaget förändras innebär att formler inte behöver göras om. Men det finns några begränsningar och en av dessa är att det inte på ett enkelt sätt går att låsa tabellreferenser. Normala områden i Excel kan man låsa med $-tecken men detta fungerar inte på tabellreferenser. Det går att låsa men det är väldigt krångligt och det finns inget kortkommando.

Ladda ner exempelfilen här.

Kopiera formel

Det vanligaste exemplet då en formel ska låsas är att den ska fungera när den kopieras. I exemplet nedan har vi en uppställning som vi sedan ska summera för en Produkt. Underlaget är en tabell och sedan ska summeringen ske i rad 22.

Vi rekommenderar dessa Excelkurser:
www.infocell.se – lärarledda kvalitetskurser i Excel
www.officekurs.se – oslagbar e-kurser i Excel & Office-paketet

Vi skapar en formel i cell D22 och använder SUMMA.OMF [SUMIFS].
=SUMMA.OMF(Produkter[Antal Q1];Produkter[Artikel];$B$20)

Detta kommer fungera då resultatet endast gäller för Q1. Men tanken är vi ska kopiera denna formel till övriga kvartal åt höger. Villkoret i cell B20 är låst och kommer inte ändras vid kopiering. Men villkorsområdet (tabellkolumn Artikel) är en tabellreferens och kan inte låsas med $-tecken och det kommer bli fel vid kopiering.

Fel vid kopiering

När formel kopieras åt höger blir det 0 i övriga celler och kikar vi närmare på en av dessa celler vad som har hänt får vi följande svar:

När formeln kopieras åt höger kommer även områdena att ”hoppa” en kolumn åt höger. Detta blir bra för värdena som ska summeras i Q2 men villkorsområdet ändras från tabellkolumn Artikel till Färg. Detta gör att formeln blir felaktig. Vi måste kunna låsa fast villkorsområdet på tabellkolumn Artikel.

Låsa tabellreferenser

Det kräver en hel del manuell hantering för att låsa en tabellreferens. Eftersom det inte finns något kortkommando så måste den låsta tabellreferensen skrivas in enligt korrekt struktur. Man anger tabellens namn samt tabellkolumnen två gången med ett kolon-tecken mellan och inom hakparenteser. Låter det krångligt? Ja, tyvärr är det krångligt.

Samma formel som tidigare fast med villkorsområdet låst denna gång:

=SUMMA.OMF(Produkter[Antal Q1];Produkter[[Artikel]:[Artikel]];$B$20)

Den gulmarkerade delen är då ett låst tabellområde. Och nu går det utmärkt att kopiera denna formel åt höger för att beräkna de övriga kvartalen.

Läs mer om våra självstudiekurser på www.officekurs.se.

Du gillar kanske också...

Gratis Kortkommandoguide för Excel!

Fyll i din e-postadress så har du strax guiden i din inkorg.

Tack!