Hitta och söka text som delvis ingår i annan cell

En bild som visar text

Automatiskt genererad beskrivning

Önskar du veta om en text eller tecken finns i en annan cell även om texten bra delvis ingår i en annan cell?

Har du provat att använda funktionen LETARAD [VLOOKUP] så har du säkert märkt att hela cellinnehållet behöver matcha varandra.

Vi ska titta på två andra funktioner som kan lösa detta problem, funktionerna HITTA [FIND] och SÖK [SEARCH].

Vi rekommenderar dessa Excelkurser:
www.infocell.se – lärarledda kvalitetskurser i Excel
www.officekurs.se – oslagbar e-kurser i Excel & Office-paketet

Ladda ner exempelfilen här.

Funktionen HITTA

En bild som visar bord

Automatiskt genererad beskrivning

Med funktionen HITTA [FIND] kan du få reda på om det eftersöka ordet eller tecknet finns i cellen och även på vilken position (antal tecken in i cellen) texten börjar.

I detta exempel vill vi se om ordet ”text” eller talet ”123” i B-kolumnen finns i motsvarande cell i A-kolumnen.

I cellen C2 har vi formeln:

=HITTA(B2;A2)

=FIND(B2;A2)

Vi anger i formeln att vi vill leta efter ordet ”text” som finns i cellen B2 och leta i cellen A2.

Och Excel ger oss svaret 1.

Excel har hittat att ordet ”text” börjar på den första positionen i cellen A2.

På rad 3 hittar Excel ordet ”text” på position 5 i cellen.

På rad 4 hittar Excel talet ”123” med början på position 6 i cellen. Även om siffrorna ”123” är en del av en text, i cellen A4, hittar programmet det vi letar efter.

På rad 5 hittar Excel inte ordet ”text” och vi får ett felmeddelande.

På rad 6 hittar Excel talet ”123” med början på position 1 i cellen. Även om siffrorna ”123” visas till höger i cellen, så finns det inga ”mellanslag” eller andra tecken framför siffrorna.

På rad 7 hittar Excel ordet ”text” på position 5 i cellen, även om bokstäverna ”text” bara ingår som en del av ordet ”texter”.

Men på rad 8 får vi också ett felmeddelande. Varför? Därför att funktionen HITTA [FIND] är känslig för stora och små bokstäver.

Funktionen SÖK

En bild som visar bord

Automatiskt genererad beskrivning

Med funktionen SÖK [SEARCH] kan du också få reda på ett eftersökt ord eller tecken finns i celler och på vilken position texten börjar, oberoende om texten är skriven med VERSALER eller gemener.

Nu hittar Excel ordet ”text” på position 9.

Startposition

En bild som visar text

Automatiskt genererad beskrivning

Funktionerna HITTA [FIND] och SÖK [SEARCH] har tre argument:

  1. Vilken text eller i vilken cell texten du vill söka efter finns.
  2. I vilken text eller cell, programmet ska leta efter texten.
  3. Men det går också att välja hur långt in (hur många tecken in) i cellen programmet ska börja leta.

Detta tredje argument är inte obligatorisk, för rubriken står inte i fetstil och kan därmed utelämnas.

En bild som visar valv, silhuett

Automatiskt genererad beskrivning Tips!

En bild som visar bord

Automatiskt genererad beskrivning

Använd funktionen OMFEL [IFERROR] för att ersätta felvärden med en valfritt värde, för att snygga till resultatet av formeln.

=OMFEL(HITTA(B2;A2);0)

=IFERROR(FIND(B2;A2);0)

 

Lägg till funktionen OM [IF] om du endast vill veta om texten hittades eller inte.

=OM(OMFEL(HITTA(B2;A2);0)>0;”Ja”;”Nej”)

=IF(IFERROR(FIND(B2;A2);0)>0;”Ja”;”Nej”)

 

Läs mer om våra självstudiekurser på www.officekurs.se.

Du gillar kanske också...

2 svar

  1. Lars Lingvall skriver:

    Tack för tipset om OMFEL, som jag inte kände till – den funktionen förenklar!

    Men i stället för
    =OM(OMFEL(HITTA(B2;A2);0)>0;”Ja”;”Nej”)
    är det enklare att skriva
    =OM(ÄRFEL(HITTA(B2;A2);”Nej”;”Ja”)

    (Dessutom: Man kan inte skriva med typografiska citattecken (”), som ni har gjort – det blev fel av den anledningen när jag kopierade formeln från er webbsida – utan man måste ju använda tumtecken (”).)

    Och funktionen SÖK verkar göra det onödigt att använda GEMENER() för ”inom_text” i HITTA().
    Men förklaringen i Excel till SÖK begriper jag inte: ”Returnerar antalet tecken vilka ett givet tecken eller textsträng söker efter först, läser från höger till vänster (ej skiftlägeskänslig)”. Antalet tecken?

    Mvh / Lars L.

    • Tobias Ljung skriver:

      Hej, tack för din variant av OMFEL. Det finns flera olika lösningar och vi presenterar en. Det är inte säkert att det är det enklaste varianten dock. Problemet med citattecken är vi medvetna om men kan inte göra något åt då det är webbsidan som automatiskt sätter dessa trots att originaltexten är rätt. Din sista kommentar angående den inbyggda förklaringen till SÖK i Excel så får du vända dig till Microsoft och försöka få detta ändrat. Det är inte det enda exemplet som är svårtolkat eller felaktigt. Många av dessa tokigheter kommer av maskinell översättning från engelska.
      Hälsningar, Robert.

Gratis Kortkommandoguide för Excel!

Fyll i din e-postadress så har du strax guiden i din inkorg.

Tack!