Granska formler via Funktionsguiden

granska formler

Om du behöver skriva så kallade nästlade formler, formler som innehåller flera funktioner inbakade i varandra, så är det praktiskt att kunna granska formler i Funktionsguiden, för att till exempel se om man vänt tecknen ”större än” > och ”mindre än” < åt rätt håll.

Ladda ner exempelfilen.

På denna camping finns det en lista i kolumn A, över alla tillgängliga stugor och en lista i kolumn D, med vilka stugor som redan är bokade inför sommaren. Nu vill vi i kolumn B se om en viss stuga redan är bokad eller inte.

Vi rekommenderar dessa Excelkurser:
www.infocell.se – lärarledda kvalitetskurser i Excel
www.officekurs.se – oslagbar e-Learning i Excel & Office-paketet

Någon har lyckats skapa dessa formler:

=OM(ANTAL.OM($D$2:$D$10;A2)>0;”Ja”;”Nej”)

=IF(COUNTIF($D$2:$D$10;A2)>0;”Ja”;”Nej”)

Funktionen ANTAL.OM [COUNTIF] tar reda på om innehållet A2 finns i området $D$2:$D$10 och om detta stämmer, returnerar funktionen ett värde som är större än >0 och sedan används funktionen OM [IF] för att fylla i svaret Ja eller Nej, om villkoret är sant eller falskt.

Knappen ”fx”

granska formler

Nu vill vi se efter om ”större än”-tecknet (>) är vänt åt rätt håll i formeln.

Gör så här:

  • Stå med markören i cellen med formeln.
  • Klicka på knappen fx, som ligger till vänster om formelfältet.
  • Funktionsguiden öppnas.

Nu kan vi, i detta exempel se, att ”större än” > eller ”mindre än” < har använts åt rätt håll.

Flera funktioner i samma formler

granska formler

Men hur gör man om det finns fler funktioner i samma formel?

Gör så här:

  1. Placera markören så den står och blinkar någonstans i namnet på nästa funktion i formeln, uppe i formelfältet.
  2. Klicka sedan på knappen fx, för att öppna Funktionsguiden.
  3. Då visas den markerade funktionen i Funktionsguiden istället.

På detta sätt går det att steg för steg kontrollera att varje funktion, i nästlade formler, returnerar rätt värden.

  • Klicka på OK för att stänga Funktionsguiden, om du ändrar på något.
  • I annat fall kan du avsluta med knappen Avbryt [Cancel] eller kortkommandot ESC.

granska formlerTips! Kortkommandot för att öppna Funktionsguiden är Shift + F3.

Besök www.officekurs.se för att hitta Excelkurser online.

Du gillar kanske också...