Unika och distinkta värden i en lista

Två begrepp när det gäller att räkna antal förekomster av element i en lista är unika värden och distinkta värden. Det finns olika metoder för att ta fram både unika och distinkta värden men i detta tips så används två olika formler.

Unika värden

Unika värden förekommer endast en gång i datamängden, alltså finns det inga dubbletter av dessa element.

Distinkta värden

Distinkta värden är första förekomsten av varje element som tillsammans bildar en sammanfattning av alla enskilda element. Det innebär att ett distinkt värde kan finnas en eller flera gånger i listan.

Excelkurs

Exempel

I bilden nedan finns en lista och där kan man tydligt se skillnaden mellan unika och distinkta värden. Alla unika ”märken” förekommer bara en gång och har inga dubbletter.

De ”märken” som är distinkta är första förekomsten för varje enskilt ”märke”. Så fort det blir en dubblett av ett tidigare ”märke” så är det inte ett nytt distinkt värde.

C:\Users\Robert\AppData\Local\Microsoft\Windows\INetCache\Content.Word\Unika och disktinka värden.png

 

Metoden är ta fram unika och distinkta värden med formler som resulterar i en förklarande text ger möjlighet att enkelt filtrera ut unika och/eller distinkta värden från en lista.

Formel för unika värden

Formeln utgår från cell B2 och kopieras sedan nedåt för resten av listan.

=OM(ANTAL.OMF($A$2:$A$10;A2)=1;”Unik”;””)

=IF(COUNTIFS($A$2:$A$10;A2)=1;”Unik”;””)

Funktionen ANTAL.OMF (COUNTIFS) räknar antalet förekomster och sedan används OM (IF) för att ställa villkoret 1 för unik förekomst som då genererar ordet Unik, annars tom cell. Viktigt att man låser hela området för listan absolut.

Formel för distinkta värden

Formeln utgår från cell C2 och kopieras sedan nedåt för resten av listan. Observera att denna formel är snarlik den tidigare men låsningen av listans område är det som skiljer. Här skapar man ett växande område allt eftersom man kopierar nedåt.

=OM(ANTAL.OMF($A$2:A2;A2)=1;”Distinkt”;””)

=IF(COUNTIFS($A$2:A2;A2)=1;”Distinkt”;””)

ANTAL.OMF används för att räkna förekomster av element I listan där listan område växer med varje rad som formeln kopieras nedåt. Därmed kan man urskilja med villkoret 1 att den första förekomsten av ett element är ett distinkt värde.

Du gillar kanske också...

Börja prenumerera på Excelbrevet

Ta del av tips & tricks i Excel och Office en gång i månaden helt kostnadsfritt.

Grattis du kommer nu att få Excelbrevet varje månad helt gratis!