Summera celler med felmeddelanden

Funktionen SUMMA (SUM) är den mest använda funktionen i Excel och vanligtvis har man inga problem att använda denna funktion. Men om man har ett område med felmeddelande i celler, som exempelvis #SAKNAS! (#N/A) eller #DIVISION/0! (#DIV/0!), så fungerar inte SUMMA-funktionen. Den kan inte ignorera celler med fel och den resulterar i ett eget fel. Se bilden nedan.

Summera med felmeddelande

Detta gäller alla olika typer av felmeddelanden som uppkommer får formler och beräkningar och för att få en korrekt summering måste man hantera eventuella felmeddelanden. Det finns olika sätt att lösa detta, här följer två lösningar.

Lösning 1

Om man har samma felmeddelande så kan man lösa en summering på ett relativt enkelt sätt. Genom att använda funktionen SUMMA.OM (SUMIF) där villkoret filtrerar bort ett felmeddelande. I bilden nedan, i den gula cellen får vi en korrekt summering av området som innehåller felmeddelande.

Excelkurs

Summera med felmeddelande

I detta exempel har vi ett felmeddelande och då kan man filtrera bort dessa celler med SUMMA.OM (SUMIF). Formeln blir:

=SUMMA.OM(B2:B6;”<>#SAKNAS!”)

=SUMIF(B2:B6;”<>#N/A”)

Summera bara celler som inte innehåller texten med felmeddelandet.

Lösning 2

Den andra lösningen blir en mycket krångligare matrisformel men den blir generell för alla typer av felmeddelanden samt om man har flera olika felmeddelanden i området som ska summeras. I bilden nedan finns det två olika felmeddelanden men med en matrisformel kan vi lösa detta.

Summera med felmeddelande

En matrisformel skapas genom att bekräfta formeln med CTRL + SHIFT + ENTER. Då skapas klammerparenteser { } runt om formeln som indikerar att det är en matrisformel.

Formeln för denna lösning blir:

=SUMMA(OMFEL(E2:E6;0))

=SUM(IFERROR(E2:E6;0))

I förklarande text så innebär denna formel att OM det finns celler med FEL så ska dessa celler betraktas som NOLL I övrigt ska cellernas värde summeras. Eftersom man skapar villkor på flera celler samtidigt så måste detta göras till en matrisformel för att fungera. Avsluta formeln med CTRL + SHIFT + ENTER.

Du gillar kanske också...

Börja prenumerera på Excelbrevet

Ta del av tips & tricks i Excel och Office en gång i månaden helt kostnadsfritt.

Grattis du kommer nu att få Excelbrevet varje månad helt gratis!